OMG what did I break this time?!

M20/M30/M50/Whatever! All engine related stuff here.
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

OMG what did I break this time?!

Postby 87e30 » Fri Jul 31, 2015 11:46 pm

So the other night there was a Corvette driving like an ass on my way home from work. He was going back and forth between lanes without signalling, leaving really slow from lights, then flying up so nobody could get in front of him, but trying to make sure when I was behind him that I'd get stuck behind the car in the other lane when the lanes merged. At one light I took off as soon as he did, and when I went to shift into 2nd my shift knob came flying off. Needless to say I missed my shift, but my feet didn't realize it as fast as my hands did. My right foot was all the way down on the gas and I redlined, leaving a nice big cloud of smoke behind me.

This engine has always run a little rich since I swapped it in. I installed 19lb injectors and an eBay chip that was supposedly programmed specifically for those injectors, and raised the rev limiter. I did notice quite a big boost in power after I installed them, especially above 4000 rpm, but it still ran just as rich as before, no real change.

After my smokeout incident the other night it seemed to drive fine the rest of the way home. The next day, however, it's putting out a lot of smoke. Smells like it's running richer than ever. Also I've lost a significant amount of power, and the exhaust is rumbling and sometimes backfiring a little bit. I could assume the problems are due to running too rich, but what could have caused it? It should also be noted that my m20b25 has been running on 5 cylinders for several months with no problems, other than shaking a little because it's out of balance with 1 cyl not doing anything at all. Both rockers from the front cylinder broke in half, so neither the intake nor the exhaust valve is opening. I disconnected the fuel injector for that cylinder so it wouldn't fill with fuel that couldn't go anywhere.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: OMG what did I break this time?!

Postby M20_fever » Mon Aug 03, 2015 3:01 pm

wait, what? Your running on 5cyl on purpose? Check the other rockers, you probably broke another when you red lined it. Why not just fix the broken rockers or buy a good used head?
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
User avatar
Yoshi
Site Admin
Posts: 9087
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: OMG what did I break this time?!

Postby Yoshi » Mon Aug 03, 2015 3:46 pm

might have broke a piston. If the cylinder hasn't been working but has been fueling, you could have pooled fuel in there and bang.
Image
Status: HG repair. 488wtq though!
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: OMG what did I break this time?!

Postby 87e30 » Mon Aug 03, 2015 6:04 pm

I'm not running it "on purpose". I'm just driving it because it's my only registered vehicle, and it does still move. I plan on replacing the broken rockers as soon as I get another vehicle running and legal because I can't be without a vehicle if I break something else while I'm in there.

The cylinder has NOT been fueling. I disconnected the fuel injector months ago.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
Yoshi
Site Admin
Posts: 9087
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: OMG what did I break this time?!

Postby Yoshi » Mon Aug 03, 2015 6:52 pm

Have you cracked open the valve cover? Once one rocker goes, the others usually aren't too far behind. Saw an M20 kill half of its rockers before the owner just replaced them all.
Image
Status: HG repair. 488wtq though!
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: OMG what did I break this time?!

Postby 87e30 » Mon Aug 03, 2015 7:46 pm

So you're telling me if I broke more rockers I'd be running twice as rich as previously (which was already choking people in cars next to me.) I'm having trouble making sense out of that.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: OMG what did I break this time?!

Postby 87e30 » Mon Aug 03, 2015 7:46 pm

Oh, another thing. It doesn't smoke anywhere near as much when the engine is cold. The warmer it gets the more smoke I'm puking out of the exhaust.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
Yoshi
Site Admin
Posts: 9087
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: OMG what did I break this time?!

Postby Yoshi » Tue Aug 04, 2015 11:07 am

fuck if I know son. break open that valve cover and report back.
Image
Status: HG repair. 488wtq though!
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: OMG what did I break this time?!

Postby M20_fever » Tue Aug 04, 2015 1:34 pm

yeah you need to check the other rockers. Wouldn't be surprised to find more broken. What kind of smoke? If it's oil smoke your symptoms point to worn valve seals. If you have more broken rockers and you are still fueling the cylinder all that fuel will wash the cylinder down and fry the rings, which would also cause a ton of blow by (smoke) and loss of compression.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop

Return to “Engine”

Who is online

Users browsing this forum: No registered users and 4 guests