Sour exhaust

M20/M30/M50/Whatever! All engine related stuff here.
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Thu Apr 07, 2016 5:52 pm

Yeah, I got bigger problems to fix first. Waiting on 145 amp alternator to arrive. My radiator split right next to the upper hose. My idle jumps between like 700ish and 1800ish after the car warms up. I'm guessing that last part was brake cleaner washing more oil residue down into the TPS when I was cleaning my throttle body and fouled out the switches inside. Also if I completely let off the gas while still in gear it takes almost a full second before I feel the engine respond, if that makes any sense. It happened right after I cleaned the TB and the ICV. I grabbed the TB with TPS off of my parts car and did the drill and clean thing on it. A LOT of crap washed out of it. Gonna swap that one in this weekend and hope it fixes the idle problem.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Sour exhaust

Postby M20_fever » Thu Apr 07, 2016 7:20 pm

Probably TPS. Make sure if you messed with it at all that you check it with a DMM. Since the e30 TPS is basically just an on/off switch and not linear like later models just a tiny bit out of adjustment and it may not be hitting the idle setting.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Fri Apr 08, 2016 12:28 am

If I'm not mistaken it's actually 2 separate on/off switches. 1 at each extreme. I just tested the one that I already drilled and cleaned and it looks like it's working fine. Fully closed makes contact until throttle is moved maybe half a mm. Fully open actually makes contact almost 1/2 inch from actually being fully open, but I don't think it should matter too much on that end.

I didn't "mess" with the one in the car. Like I said, I'm assuming some brake cleaner seeped down while I was cleaning the TB and freed up some chunks that got where they don't belong.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Sour exhaust

Postby M20_fever » Fri Apr 08, 2016 1:43 pm

you are correct, two contact points, fully closed idle, and WOT.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Fri Apr 08, 2016 10:08 pm

Last night I went to test the TPS installed in the car after work and the damn cheap ass probe from the Harbor Freight freebie multimeter just fell apart. I was able to wrap the one wire around the center pin and touch the other "functioning" probe to each of the other 2 pins. Fully closed switch seems to be working, but wide open not at all. I would have expected the opposite from how the car is acting. When I put everything back together I forgot to plug the TPS back in and didn't even realize it until I noticed the car was idling REALLY high. Plugged it back in and everything back to the way it's been.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Sour exhaust

Postby M20_fever » Mon Apr 11, 2016 1:58 pm

Did you try to adjust the TPS? Usually just loosening the screws and moving it a hair will get you back into both positions.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Mon Apr 11, 2016 2:07 pm

No I didn't try adjusting it. It wasn't out of adjustment before I went on a cleaning spree, so I wouldn't imagine it would be afterwards. I didn't have time to swap anything out over the weekend either. I was really hoping to get that new alternator in.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Fri Dec 30, 2016 1:48 am

Man I suck at updates. I swapped the alternator and throttle body MONTHS ago! Well, not THAT many months ago, but it's been a while. Maybe in August? Those problems are just about gone. My idle still jumps once in a blue moon. Maybe a tiny vacuum leak somewhere?
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
Yoshi
Site Admin
Posts: 9087
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: Sour exhaust

Postby Yoshi » Fri Dec 30, 2016 2:09 am

Man you ARE horrible.
Image
Status: HG repair. 488wtq though!
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Sour exhaust

Postby 87e30 » Fri Dec 30, 2016 2:23 am

So sue me! You won't get much. lol
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban

Return to “Engine”

Who is online

Users browsing this forum: No registered users and 5 guests