87 325e dies on acceleration when warm

M20/M30/M50/Whatever! All engine related stuff here.
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Sun Oct 28, 2018 12:03 am

I bought 1987 325 4 door and it’s been giving me the same problem the last two months The kid I bought the car from did some real ghetto things to it like a c-clamp to hold the valve cover where he broke a stud and oil dumps out where it’s being held during high revs he slammed it to the ground with “custom” engine spacers So my main problem is whenever the car gets to operating temperature and sometimes cold it’ll just cut out it runs great for like 5 min until it gets warm enough where if I’m accelerating and anywhere past 2,500 rpm or above will just die slowly until idle and sometimes shuts off and it’ll take awhile to start up. I changed the tps fuel filter engine coolant sensor ignition coil cap and rotor I have no idea what it could be and don’t think that valve cover would be a problem since it only does it when warm me and a friend @87e30 tested the fuel pump when it cut out and no change in power to the wires I’m so lost on this and just want something to daily while I try and save money to fix my current daily thanks to anyone with input and advice really need it
User avatar
87e30
I <3 E30's
Posts: 2014
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: 87 325e dies on acceleration when warm

Postby 87e30 » Mon Oct 29, 2018 4:11 am

Yes, I'm still alive everyone. Just haven't been online much since we moved our shop to a new location, and 99% of my tows are out of state, so I don't spend much time in my office, and am too exhausted to get online from home.

We also swapped the AFM with the known working one from my car with no change. Looks like the PO already cleaned out the TB and TPS, probably trying to fix the same problem, because most people seem to think the problem is either the TPS or the coil. I believe the car has the same problem with multiple ECUs, so that can be ruled out. We don't have a fuel pressure gauge yet, so not sure if the cutting out is due to lack of fuel or spark.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
Yoshi
Site Admin
Posts: 9092
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: 87 325e dies on acceleration when warm

Postby Yoshi » Mon Oct 29, 2018 11:12 am

What does the car sound like when it's slowly dying? Just slowing down or does it actually feel like it's misfiring? I'd point towards fuel pressure more than anything ignition related. Could also be the crank position sensor but that doesn't make sense if it's an engine heat issue. Fuel pressure gauge will tell you a lot. If fuel pressure is fine, then we go back to ignition issues. I've seen old plug wires have issues when the car gets hot.
Image
Status: HG repair. 488wtq though!
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Mon Oct 29, 2018 5:45 pm

Thanks for the reply and it just slowly dies till I press the clutch in to idle or down shift but latley if I continue driving it with the problem it would just slow down and die then take awhile to start up I guess I’ll go to harbor freight and buy a fuel pressure gauge and let u guys know hopefully it’s fuel cuz I have some parts laying around
User avatar
87e30
I <3 E30's
Posts: 2014
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: 87 325e dies on acceleration when warm

Postby 87e30 » Mon Oct 29, 2018 10:44 pm

I would describe it more like an abrupt total cut than a slow death.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
87e30
I <3 E30's
Posts: 2014
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: 87 325e dies on acceleration when warm

Postby 87e30 » Mon Oct 29, 2018 11:23 pm

Why don't you pet those videos on youtube and post em up in the thread?
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Tue Oct 30, 2018 6:32 am

https://youtu.be/t6pYxhDpt7Q


The whole time I was either wide open or little throttle and every time it would die it would be on its own lost on this car
User avatar
87e30
I <3 E30's
Posts: 2014
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: 87 325e dies on acceleration when warm

Postby 87e30 » Tue Oct 30, 2018 12:24 pm

Bmwforbossmanswhip wrote:


Fixed that for ya. You can imbed the video instead of linking to it.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Tue Oct 30, 2018 4:37 pm

Thhhaannkkk you hopefully somebody can figure this out I gotta really get that gauge
User avatar
87e30
I <3 E30's
Posts: 2014
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: 87 325e dies on acceleration when warm

Postby 87e30 » Tue Oct 30, 2018 6:25 pm

Hrm, video doesn't work on my phone when embedded, but it does work in the youtube app.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
Yoshi
Site Admin
Posts: 9092
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: 87 325e dies on acceleration when warm

Postby Yoshi » Wed Oct 31, 2018 12:35 pm

Looks like something electrical. Like a wire is coming loose for a little bit. Still thinking fuel pump.
Image
Status: HG repair. 488wtq though!
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Wed Oct 31, 2018 6:08 pm

Wire coming loose seems like a good reason but doesn’t explain why it only happens when warm. I never have time to go to harbor freight for that gauge,I should go tonight gotta get it going just found out my e39 engine mount bracket snapped in half
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Thu Nov 01, 2018 3:58 am

So I got the fuel pressure gauge and I guess I gotta hook it up when cold but would there be no point when cold since it runs normally or wait till it’s gets warm and acts up to read I’m lost I just need this pos to drive everyday 20 min
User avatar
Yoshi
Site Admin
Posts: 9092
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: 87 325e dies on acceleration when warm

Postby Yoshi » Fri Nov 02, 2018 11:14 am

Hook it up when cold so there's no pressure but look at it when warm. I just normally leave the gauge on my cars permanently.
Image
Status: HG repair. 488wtq though!
Bmwforbossmanswhip
n00b
Posts: 10
Joined: Fri Oct 26, 2018 4:15 pm
AntiSpam: No

Re: 87 325e dies on acceleration when warm

Postby Bmwforbossmanswhip » Tue Nov 06, 2018 7:02 am

So I hooked it up and it got 32 then everytime it cut off dropped to 0 so ima buy a fuel pump

Return to “Engine”

Who is online

Users browsing this forum: No registered users and 2 guests