Problem with new rotor and brake pads

From the tranny down to wheel bearings.
dahabit
E30 Guy
Posts: 53
Joined: Sat Mar 08, 2014 6:00 pm
AntiSpam: No

Problem with new rotor and brake pads

Postby dahabit » Thu Jun 19, 2014 3:33 pm

Gang,

I replaced my rear rotor and brake pad on my e30. Something didn't seem quite right, so I took a short video of it.
I'm no expert but I don't think it is supposed to wobble like that. What do you guys think?

https://www.youtube.com/watch?v=BwFmDJngXZQ
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Problem with new rotor and brake pads

Postby 87e30 » Thu Jun 19, 2014 4:54 pm

Are both sides wobbling like that? These are brand new rotors? When you put them on did they sit flush, or did it seem like they went on unevenly? Looks like they might be warped or on crooked. Maybe take them back off and clean really well behind them then remount and make sure they go on evenly all around.

Also can you post a longer video, and include an angle that shows the axle? Couldn't really tell, but it could be a bad axle making everything wobble. Shoot for at least 30 seconds and move the camera around to show more angles.
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
dahabit
E30 Guy
Posts: 53
Joined: Sat Mar 08, 2014 6:00 pm
AntiSpam: No

Re: Problem with new rotor and brake pads

Postby dahabit » Fri Jun 20, 2014 4:19 am

FML.

I started to remove everything so I could clean. But unfortunately the hex screw holding up the rotor got stripped. So I'm back to square 1.
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Problem with new rotor and brake pads

Postby M20_fever » Fri Jun 20, 2014 1:21 pm

No biggie on the hex bolt, just drill it with a 1/4" bit and use an ez out to extract it. You don't need to use them, but if you do put a dab of anti seize on it. As far as the rotor wobble, a good inspection should make the problem obvious. Either bad rotor, or bad axle. Also make sure the rotor seated fully since it needs to slide all the way over the parking brake. If it was the axle I would think you would have felt it before the brake job.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
User avatar
Yoshi
Site Admin
Posts: 9086
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: Problem with new rotor and brake pads

Postby Yoshi » Sun Jun 22, 2014 8:15 pm

Either the rotor is warped or there is something between the rotor and the hub itself. pebble or something.
Image
Status: HG repair. 488wtq though!

Return to “Drive Line”

Who is online

Users browsing this forum: No registered users and 2 guests