New SI Board - still no speedo or tach? - ***SOLVED***

Why do I have to unlock my doors through my trunk?
User avatar
blasphemy101
I <3 E30's
Posts: 1041
Joined: Sat Apr 07, 2012 9:20 pm
AntiSpam: No

Re: New SI Board - still no speedo or tach? - ***SOLVED***

Postby blasphemy101 » Sat Apr 14, 2012 5:38 am

Maybe - I plan on starting a project thread, where I can pose these kinds of questions in bulk, then move them to the other forums if I have trouble finding my answer.
pr0craztinazn
I <3 E30's
Posts: 490
Joined: Sun Aug 16, 2009 2:01 am
AntiSpam: No
Location: MD
Contact:

Re: New SI Board - still no speedo or tach? - ***SOLVED***

Postby pr0craztinazn » Sat Apr 14, 2012 2:34 pm

I think candlepower stocks the correct bulbs to replace the stock units. I wouldn't put LEDs in there, as that faux backlighting effect goes to hell when too much light gets reflected back at you, and is made far worse with chrome cluster trim rings.

Nice detective work! I forsee a fun project thread coming from you.
User avatar
blasphemy101
I <3 E30's
Posts: 1041
Joined: Sat Apr 07, 2012 9:20 pm
AntiSpam: No

Re: New SI Board - still no speedo or tach? - ***SOLVED***

Postby blasphemy101 » Sun Apr 15, 2012 12:16 am

LOL "fun" is one word for it. Initial plan is to get it running strong as a stock motor tuned on a WAR chip. A small turbo is somewhere down the line >:)

But yes, I'm going to try to get the project thread up soon. I just need to get some current pictures :)

Return to “Electrical”

Who is online

Users browsing this forum: No registered users and 1 guest