Turn Signal stalk not working

Why do I have to unlock my doors through my trunk?
sonic reducer
n00b
Posts: 6
Joined: Sat Jun 07, 2014 8:58 pm
AntiSpam: No

Turn Signal stalk not working

Postby sonic reducer » Sat Jun 07, 2014 9:46 pm

just picked up a mega clean 325is. well at least the paint is haha. it's got some annoying little issues one of which is that the right turn signal was non-op.
So I *believe* the problem is the turn signal switch at the stalk. after some head scratching and staring at the wiring diagrams I decided to just jumper from the green/yellow input wire of the switch to the blue/black that is the switch output for the right signal and behold the right signal worked. this basically proves that the switch itself is the issue yes?

I'm going to attempt just blasting out the switch with contact cleaner. hopefully this fixes it but if not...

is there a way to restore the switch guts? I'm leery of trying to disassemble it without knowing what the heck I'm doing.

has anyone here replaced a turn signal switch? the wires are soldered at the switch and run off into the harness. If I end up having to replace the switch, what's the best course of action? cut and solder at the switch? try and unwrap the harness and pull the connector pins?
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Turn Signal stalk not working

Postby 87e30 » Mon Jun 09, 2014 1:28 am

I thought there was a connector in there for it. Have you checked the solder connections on the switch, or checked the functionality of the switch with a multimeter? I just spent 3 days on my own 325is trying to figure out why the blinkers (and other things) stopped working... Turned out to be a bad solder connection inside of the fuse box. So check those solder connections first.

If the switch definitely IS bad, and there's no connector to unplug, you should just be able to cut the wires and use some butt connectors to hook up the new switch. Never tried to take one apart to see if it could be fixed. I guess ANYTHING can be fixed if you have the time and patience. Would most likely be much less of a headache just getting another one out of a yard though.

EDIT - btw Welcome to the board! We demand pics and a build thread! -grin-
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
pr0craztinazn
I <3 E30's
Posts: 490
Joined: Sun Aug 16, 2009 2:01 am
AntiSpam: No
Location: MD
Contact:

Re: Turn Signal stalk not working

Postby pr0craztinazn » Mon Jun 09, 2014 11:33 am

There can be carbon buildup in the switch, but getting the plastic off without breaking it is not easy for a hamfisted oaf like myself. Clean that out, and if the contacts aren't destroyed, it should be ok. I haven't tried this in a while, but I believe these unplug, so you shouldn't have to cut and splice.
User avatar
Yoshi
Site Admin
Posts: 9086
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: Turn Signal stalk not working

Postby Yoshi » Mon Jun 09, 2014 11:41 am

I always have a few spares for this reason. I've never been able to fix one but I admittedly haven't tried too hard.
Image
Status: HG repair. 488wtq though!
sonic reducer
n00b
Posts: 6
Joined: Sat Jun 07, 2014 8:58 pm
AntiSpam: No

Re: Turn Signal stalk not working

Postby sonic reducer » Tue Jun 10, 2014 4:12 am

well the contact cleaner did it!

I guess the main thing I learned is to do some critical thinking about what your issues could be, based on process of elimination. for instance I took the gauge cluster out before realizing that there was no real need to do that because the hazard lights caused both dash indicator lights to come on. etc.

next project: fix the door locks :shock:
sonic reducer
n00b
Posts: 6
Joined: Sat Jun 07, 2014 8:58 pm
AntiSpam: No

Re: Turn Signal stalk not working

Postby sonic reducer » Tue Jun 10, 2014 4:28 am

87e30 if I did a build thread it would probably bore people to tears! I'm doing a simple clean up/fix up/resto on what is already a pretty decent car. I tried to post a pic of it but it was much too large for the uploader.
User avatar
Yoshi
Site Admin
Posts: 9086
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: Turn Signal stalk not working

Postby Yoshi » Tue Jun 10, 2014 11:11 am

Host externally and link or down size your pictures. Most cameras now a days take HUGE pictures and our hosting doesn't have enough size for it.

Also, boring builds are ok lol. I want to get my door locks working again. It's so far down on my list though.
Image
Status: HG repair. 488wtq though!
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Turn Signal stalk not working

Postby 87e30 » Tue Jun 10, 2014 12:33 pm

+1 on getting locks working again. Hopefully I'll get around to that this weekend and install the keyless entry system that's been sitting behind my desk for over a year.

If you're using Windoze you should get a program called Irfanview. It makes basic image manipulation fast and easy. You can resize single or multiple files (in batch mode) to get them small enough to post. I've found if I resize so the longest side is 800px I can easily attach 3 pictures to a post.

Even if you think your build is boring it could still contain something that helps someone else. Plus we obviously all love seeing e30's. :-)
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
sonic reducer
n00b
Posts: 6
Joined: Sat Jun 07, 2014 8:58 pm
AntiSpam: No

Re: Turn Signal stalk not working

Postby sonic reducer » Wed Jun 11, 2014 1:02 am

thanks for the heads up on that program, I'm not the most computer literate guy in the world so its nice to learn some stuff. looks legit I'll have to resize some pics with it.
sonic reducer
n00b
Posts: 6
Joined: Sat Jun 07, 2014 8:58 pm
AntiSpam: No

Re: Turn Signal stalk not working

Postby sonic reducer » Wed Jun 11, 2014 2:17 am

some pics.
dunno what to do about that damn windshield trim. is there a dye that could at least make it not stand out that way?

got a line on a 5sp swap from a parts car, the guy said $300 for everything does that sound like an ok price?
Attachments
bmw 020.JPG
bmw 020.JPG (122.81 KiB) Viewed 4064 times
bmw 001.JPG
bmw 001.JPG (99.68 KiB) Viewed 4064 times
User avatar
Yoshi
Site Admin
Posts: 9086
Joined: Thu Feb 26, 2009 7:47 pm
AntiSpam: No
Location: North VA
Contact:

Re: Turn Signal stalk not working

Postby Yoshi » Wed Jun 11, 2014 11:12 am

$300 for all the swap parts sound great! You'll want a new clutch and to machine the flywheel but other than that, you're good to go!

For the front window trim, It comes out, you can replace it with another one but I never figured out where to get it. I always had it replaced whenever I smashed out a front window (3x now...)
Image
Status: HG repair. 488wtq though!
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Turn Signal stalk not working

Postby M20_fever » Tue Jun 17, 2014 4:45 am

Nice clean starter you got there, welcome to the board. Do a detailed write up with pics and instructions for one of your projects and I'll send you some site window decals so you can represent, lol.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop
e30 baur
n00b
Posts: 8
Joined: Thu Aug 28, 2014 7:26 am

Re: Turn Signal stalk not working

Postby e30 baur » Fri Mar 27, 2015 7:13 am

If you haven't done so already, you can get a new chrome window surround direct from bmw for 50 or so. You will also need the bottom clip for the joint at about 20. Got one myself a few weeks ago.
User avatar
87e30
I <3 E30's
Posts: 2008
Joined: Wed Oct 27, 2010 5:25 pm
AntiSpam: No
Location: New Jersey

Re: Turn Signal stalk not working

Postby 87e30 » Wed Jul 22, 2015 10:56 pm

It's funny how some parts for our cars are actually much CHEAPER to buy direct from the dealer than aftermarket. I wonder whatever happened to the original poster of this thread. Never started that build thread. :-(
Schwarz 5-speed 87 325is (newest project)
Arktisblau 5-speed 86 325e (current DD)
Schwarz 5-speed 87 325e (parts car/LS1 swap?)
Gazellenbeige automatic 85 318i (70,000 miles)
Alpine white 5-speed 87 325is (my first e30, possibly for sale)
99 Suburban
User avatar
M20_fever
Größter Vorsitzender
Posts: 11026
Joined: Fri Feb 27, 2009 1:28 pm
AntiSpam: No
Location: Northern IL

Re: Turn Signal stalk not working

Postby M20_fever » Thu Jul 23, 2015 12:59 pm

yeah bummer, I was looking forward to a Baur build.
Image
Midwestern Councel C Prepared class champion 2012
North Suburban Sports Car Club C Prepared class champion 2012
HSAX Instructor

GET YOUR E3P GEAR HERE: http://www.cafepress.com/e3pgearshop

Return to “Electrical”

Who is online

Users browsing this forum: No registered users and 2 guests